网络探测

2024-05-30 19:48
文章标签 网络 探测

本文主要是介绍网络探测,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Problem Description
When the network runs into trouble, we often use the command “ping” to test whether the computer is well connected to others.
For example, if we want to test whether our computer is well connected to the host of Zhongshan University, we would use the command “ping www.zsu.edu.cn”. Then if the network works well, we would get some replies such as:
Reply from 202.116.64.9: bytes=32 time=1ms TTL=126
Reply from 202.116.64.9: bytes=32 time<1ms TTL=126
But how can we get a reply with the whole information above, especially the time used? As follows are some details about the “Ping” process, and please note that this explanation is for this problem only and may be different from the actual “Ping” command:
First of all, there are two kinds of message related to this “Ping” process, the echo request and echo reply. 
The echo request message contains a TimeElapsed field to record the time used since it’s sent out from the source. We can assume that in the network, each host (router, switcher, computer, and so on) is so “polite” that if the incoming message does not aim to itself, then it will update the TimeElapsed field in the message with the time used to transfer the message from the direct sender to itself, and send the message to all the other hosts that is connected to them directly. So after we send out an echo request packet, the network can “automatically” transfer it to the target host. 
Once the target host receives an echo request message, it replies with an echo reply message. The echo reply message also contains a TimeElapsed field, which is filled by the target host using the TimeElapsed field in the echo request message, and will not be changed by those intermediate computers. Then the network “automatically” transfers the reply to us again. That’s why we know whether the network is well connected or not, and the shortest time it takes to transfer a message from our computer to the target host. 
Actually, there is still one problem with the “Ping” process above. Suppose intermediate computers A and B are directly connected to each other, and a message aiming to C reaches A, then A will transfer the message to B since A is “polite”, and then B will send the message back to A again since B is “polite” too, then A and B are trapped into an infinite loop and keep on sending message to each other. To solve this problem, a host would throw away an incoming message if the message has been transferred for more than ten hops (Each time a host A sends a message to another host B is called one hop).
The problem is, given the details of the network, what is the reply time we will get. Please note that this reply time will equal to the shortest time to transfer a message from the source to the target host if possible.
Input
The input will contain multiple test cases. In each test case, the first line is three integers n (n<=1000), m and t (0<=t<n), n is the number of hosts in the network (including our computer), m is the number of pairs of directly connected computers, and t is the target host that we would like to ping. (We always assume our computer to be host 0).
Then there are m lines followed, each of which has three integers a (0<=a<n), b (0<=b<n) and c (0<c<=1000), indicating that host a is directly connected to b, and the time required to transfer a message from a to b or vice versa is equal to c. 
The input will be terminated by a case with n=0, which should not be processed.
Output
For each case, if our computer can get the reply from the target computer, print the reply time in one line. Otherwise print “no”.
Sample Input
3 2 2
0 1 2
1 2 3
3 1 2
0 1 2
0 0 0
Sample Output
5
no
//题意:给出一个无向连通图G,起点是0,终点是t,求不超过10步的最短路径的花费是多少。
//关键字: SPFA + DP
//标程:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
const int inf = 100000000;
struct node
{int v, w;node(int x,int y){v = x;w = y;}
};
vector<node> vec[1010];
int n, m, t, vis[1010], dis[1010][11];
void spfa(int s)
{queue<int> q;while(!q.empty()) q.pop();q.push(s);for(int i = 0; i < n; ++ i)for(int j = 0; j <= 10; ++ j)dis[i][j] = inf;dis[s][0] = 0;memset(vis,0,sizeof(vis));while(!q.empty()){int u = q.front();q.pop();vis[u]=0;for(int i = 0;i < vec[u].size();i++){int v = vec[u][i].v;for(int j = 1; j <= 10; j ++){if(dis[v][j] > dis[u][j-1] + vec[u][i].w){dis[v][j] = dis[u][j-1] + vec[u][i].w;if(!vis[v]){q.push(v);vis[v]=1;}}}}}
}
int  main()
{
//    freopen("a.txt","r",stdin);int  i;while(cin >> n >> m >> t,n+m+t){for(i = 0; i <= n; ++ i) vec[i].clear();int a, b, w;for(i = 1; i <= m; ++ i){cin >> a >> b >> w;vec[a].push_back(node(b,w));vec[b].push_back(node(a,w));}spfa(0);int ans = inf;for(i = 0; i <= 10; ++ i)if(ans > dis[t][i])ans = dis[t][i];if(ans < inf) cout << ans << endl;else cout << "no" << endl;}return 0;
}


                                    

这篇关于网络探测的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1016783

相关文章

Linux 网络编程 --- 应用层

一、自定义协议和序列化反序列化 代码: 序列化反序列化实现网络版本计算器 二、HTTP协议 1、谈两个简单的预备知识 https://www.baidu.com/ --- 域名 --- 域名解析 --- IP地址 http的端口号为80端口,https的端口号为443 url为统一资源定位符。CSDNhttps://mp.csdn.net/mp_blog/creation/editor

ASIO网络调试助手之一:简介

多年前,写过几篇《Boost.Asio C++网络编程》的学习文章,一直没机会实践。最近项目中用到了Asio,于是抽空写了个网络调试助手。 开发环境: Win10 Qt5.12.6 + Asio(standalone) + spdlog 支持协议: UDP + TCP Client + TCP Server 独立的Asio(http://www.think-async.com)只包含了头文件,不依

poj 3181 网络流,建图。

题意: 农夫约翰为他的牛准备了F种食物和D种饮料。 每头牛都有各自喜欢的食物和饮料,而每种食物和饮料都只能分配给一头牛。 问最多能有多少头牛可以同时得到喜欢的食物和饮料。 解析: 由于要同时得到喜欢的食物和饮料,所以网络流建图的时候要把牛拆点了。 如下建图: s -> 食物 -> 牛1 -> 牛2 -> 饮料 -> t 所以分配一下点: s  =  0, 牛1= 1~

poj 3068 有流量限制的最小费用网络流

题意: m条有向边连接了n个仓库,每条边都有一定费用。 将两种危险品从0运到n-1,除了起点和终点外,危险品不能放在一起,也不能走相同的路径。 求最小的费用是多少。 解析: 抽象出一个源点s一个汇点t,源点与0相连,费用为0,容量为2。 汇点与n - 1相连,费用为0,容量为2。 每条边之间也相连,费用为每条边的费用,容量为1。 建图完毕之后,求一条流量为2的最小费用流就行了

poj 2112 网络流+二分

题意: k台挤奶机,c头牛,每台挤奶机可以挤m头牛。 现在给出每只牛到挤奶机的距离矩阵,求最小化牛的最大路程。 解析: 最大值最小化,最小值最大化,用二分来做。 先求出两点之间的最短距离。 然后二分匹配牛到挤奶机的最大路程,匹配中的判断是在这个最大路程下,是否牛的数量达到c只。 如何求牛的数量呢,用网络流来做。 从源点到牛引一条容量为1的边,然后挤奶机到汇点引一条容量为m的边

配置InfiniBand (IB) 和 RDMA over Converged Ethernet (RoCE) 网络

配置InfiniBand (IB) 和 RDMA over Converged Ethernet (RoCE) 网络 服务器端配置 在服务器端,你需要确保安装了必要的驱动程序和软件包,并且正确配置了网络接口。 安装 OFED 首先,安装 Open Fabrics Enterprise Distribution (OFED),它包含了 InfiniBand 所需的驱动程序和库。 sudo

【机器学习】高斯网络的基本概念和应用领域

引言 高斯网络(Gaussian Network)通常指的是一个概率图模型,其中所有的随机变量(或节点)都遵循高斯分布 文章目录 引言一、高斯网络(Gaussian Network)1.1 高斯过程(Gaussian Process)1.2 高斯混合模型(Gaussian Mixture Model)1.3 应用1.4 总结 二、高斯网络的应用2.1 机器学习2.2 统计学2.3

网络学习-eNSP配置NAT

NAT实现内网和外网互通 #给路由器接口设置IP地址模拟实验环境<Huawei>system-viewEnter system view, return user view with Ctrl+Z.[Huawei]undo info-center enableInfo: Information center is disabled.[Huawei]interface gigabit

Golang 网络爬虫框架gocolly/colly(五)

gcocolly+goquery可以非常好地抓取HTML页面中的数据,但碰到页面是由Javascript动态生成时,用goquery就显得捉襟见肘了。解决方法有很多种: 一,最笨拙但有效的方法是字符串处理,go语言string底层对应字节数组,复制任何长度的字符串的开销都很低廉,搜索性能比较高; 二,利用正则表达式,要提取的数据往往有明显的特征,所以正则表达式写起来比较简单,不必非常严谨; 三,使

Golang网络爬虫框架gocolly/colly(四)

爬虫靠演技,表演得越像浏览器,抓取数据越容易,这是我多年爬虫经验的感悟。回顾下个人的爬虫经历,共分三个阶段:第一阶段,09年左右开始接触爬虫,那时由于项目需要,要访问各大国际社交网站,Facebook,myspace,filcker,youtube等等,国际上叫得上名字的社交网站都爬过,大部分网站提供restful api,有些功能没有api,就只能用http抓包工具分析协议,自己爬;国内的优酷、