HDU 4786

2024-05-27 13:58
文章标签 hdu 4786

本文主要是介绍HDU 4786,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

      很好的一道题目,考验人的解决问题的思路。如果你想直接解出这道题的答案,感觉会无从下手,但是如果你只是求出一个可能包含答案的区间,然后在区间内搜索,那么解决起来就简单了。

      我们可以按照把1和0分别当做黑边和白边的权值,求出最大生成树和最小生成树。其中,最大生成树中白边的数量代表所有生成树中白边最少需要多少条,最小生成树代表白边最多有多少条。如果这个区间内包含斐波那契数,则说明存在符合题意的斐波那契树,否则就不存在。

     此外,还要注意图的连通性。不连通的图是不存在生成树的,也就是没答案的。

代码(C++):

#include <iostream>
#include <cstdio>
#include <algorithm>#define MAX 100009
using namespace std;struct Edge{int a;int b;int w;
} edge[MAX];int c,fib[25],pre[MAX],num;void add_edge(int a,int b,int w)
{edge[c].a=a;edge[c].b=b;edge[c].w=w;c++;
}bool cmp1(Edge x,Edge y)
{if(x.w!=y.w) return x.w<y.w;if(x.a!=y.a) return x.a<y.a;return x.b<y.b;
}bool cmp2(Edge x,Edge y)
{if(x.w!=y.w) return x.w>y.w;if(x.a!=y.a) return x.a>y.a;return x.b>y.b;
}int find(int v)
{if(pre[v]!=v) pre[v]=find(pre[v]);return pre[v];
}void merge(int a,int b)
{pre[a]=b;
}int kruskal(int n)
{int i,count,pre_a,pre_b,a,b;count=num=0;for(i=1;i<=n;i++) pre[i]=i;for(i=0;i<c;i++){a=edge[i].a;b=edge[i].b;pre_a=find(a);pre_b=find(b);if(pre_a!=pre_b){merge(pre_a,pre_b);if(edge[i].w==1) count++;num++;}if(num==n-1) break;}return count;
}int main()
{//freopen("in.txt","r",stdin);int t,n,m,a,b,w,i,k,num1,num2;fib[0]=1;fib[1]=2;for(i=2;i<25;i++){fib[i]=fib[i-1]+fib[i-2];}scanf("%d",&t);for(k=1;k<=t;k++){scanf("%d %d",&n,&m);c=0;for(i=0;i<m;i++){scanf("%d %d %d",&a,&b,&w);add_edge(a,b,w);}sort(edge,edge+c,cmp1);num1=kruskal(n);//如果图不连通,则直接输出"No"if(num<n-1){printf("Case #%d: No\n",k);continue;}sort(edge,edge+c,cmp2);num2=kruskal(n);for(i=0;i<25;i++){if(fib[i]>=num1&&fib[i]<=num2) break;}if(i==25) printf("Case #%d: No\n",k);else printf("Case #%d: Yes\n",k);}return 0;
}

题目( http://acm.hdu.edu.cn/showproblem.php?pid=4786):

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )

Input
The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).

Output
For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.

Sample Input
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1

Sample Output
  
Case #1: Yes Case #2: No

这篇关于HDU 4786的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1007676

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时